I’ve been a user of Logitech Harmony remotes for many years (since at least 2006), and have had several models.

The first, and my favorite, was a 659. I purchased it as a “universal remote” based on Logitech’s Activity premise, which is that when using any Harmony remote, the core use of the remote was to switch “Activities” – watching TV, playing movies, listening to music etc. – rather than follow the prevailing Universal Remote theme of pretending to be five different remotes.

To watch a movie, a typical remote would require you to:

  • Press “Control TV” button
  • press Power
  • press Input, and push up/down to scroll to VCR, push Select
  • pressĀ “Control VCR” button
  • press Power
  • press Play

Instead, A Harmony would set up all devices as necessary for the selected Activity (Watch Movie: remote sends commands to turn on TV, set input to VCR, turn on VCR, press Play) with just one button.

Many universal remotes can be programmed with Macros – strings of commands like those above that can be assigned to a key. Well and good. Where the Harmony differed in that it would remember what state each device was in, and act accordingly as the system was in use. To illustrate, if I started my evening watching a movie (pressing the Watch Movie button, at which the Harmony would turn the TV on and set to VCR, and turn on the VCR and push Play) and then decided to watch plain old TV when the movie finished, a press of the “Watch TV” button would turn off the VCR, turn on the cable box, and set the TV to “Cable box” input – without me having to remember which magic set of macros to use. The Harmony just took care of it all.

If it ever got out of sync (thinking a given component was on when it was powered off, for example), the Help button would walk step-by-step through simple yes/no questions until things were back in harmony (yes, I specialize in poor punnery).

The only trouble I ever had with it was a USB connector that came loose on the first one; it got to the point I couldn’t reprogram the unit from my computer. Logitech promptly replaced it and the replacement worked fine for many years. Various components in my A/V area were swapped out for new ones (DVR updates, new receiver &c. &c.) and it was always trivial to update the remote to accommodate. New software would come out regularly to add new features. Eventually the setup included multiple audio players (SACD and DVD-A, remember those?), a good receiver, a DVD player and other items. The remote kept up with all of them.

A New Flame

Eventually the 659 “passed on” from old age. It was replaced with a Harmony One, a touchscreen model. Copying the settings from the old remote to the new was also a painless process. The fundamentals of the remote were exactly the same.

I tried numerous HD-DVD and BluRay players, in particular for streaming movies from a central server, and ended up using a PS3 for the task. It can stream full 1080p video with uncompressed 7.1 channel audio, which most stand-alone units couldn’t do. The downside? Its remote controller is RF based, meaning my trusty Harmony (being IR-only) couldn’t talk to it. For a reasonable cost, Logitech sells an adapter to connect the remote to the PS3 – problem solved, and another device added to the mix.

The One had one issue I never did solve: when turning on from an “all devices off” condition, it would refuse to wait long enough for the receiver to power on and accept further infrared commands. The remote would send “power on” and then immediately send “change input” – which the receiver would ignore, as it wasn’t all the way “on” yet. Without fail, if the new activity wasn’t the same as the one in use at last power-off, I would have to wait for all the commands to be sent, hit the “Activities” button, and then re-initiate the activity I wanted – THEN it would switch the input. I lived with it, but it drove everyone else in the house nuts.

Eventually the screen on the One got broken (someone sat on it, apparently). It continued working for a few weeks, as long as I could guess the area of the touchscreen that had the desired command. A few days ago, it finally quit working completely.


I purchased a new 650 model (which is a lower number than the first one I had, even though it has a color screen – go figure) this week from a big-box retailer. I looked at the Touch and the Ultimate. The Touch was more than twice the money, and many reviewers complain of battery life issues. The Home – well, I don’t have anything in the way of IOT devices, and paying FIVE times as much “just in case I got some later” just didn’t make sense.

The First Pisser

I went to the Logitech site to double-check that I had the latest version of the Harmony software. It matched what was installed (despite its being over three years old!), and the page told me I could use that to set up my new remote.

I started up my old Harmony software, and before I could even log in, the opening screen promptly tells me that it can not be used with the 650, and to go to myharmony.com to set it up.

Well, crap. Make up your minds.

It offered me a “Go to MyHarmony.com” link at the bottom of the screen, which I obligingly clicked. A new window opened, and that window tells me that it can’t be run at the same time as the Harmony software, which had started it with that one simple button click. So I have to switch back to the other window to shut it down, then return to the new window to carry on.

When I tried to log in, the username/password I provided was incorrect (it had been a long time since I needed to update my One). I clicked the “forgot password” button. I filled in my email address, and clicked Reset. It promptly informed me that my email address was not valid.


Double-checked my email address (found the address used for support calls and also some old “reset password” emails) and tried again.

No go.

So … I created a new account and set up the remote.

As it turns out, I should have used the “username” instead of email when logging in – but it wouldn’t accept that when attempting to reset the password, so it would have done me no good without also remembering the password.

The SECOND and third Pissers

Once I got a new account set up, it asked me to plug in the remote to the USB port (and install batteries if need be).

The remote is packaged in one of those blister packs of hard clear plastic (decidedly anti-theft, and not frustration-free) and I proceeded to cut around the outside with a pair of sharp scissors. Despite cutting as close the scissors would get to the package body proper, I could not get the package to open. Ended up cutting into the package, being careful not to cut the new remote, myself or the USB cable. Still, it did not want to relinquish its contents. Finally, with a really hard pull, the package came apart – into about 15 pieces, ranging from half the clamshell to a bunch of shards where it finally gave which fell all over my lap and feet. They were kind of sharp, and I had to clean them up to keep the dogs from chewing them and injuring themselves.

Beautiful, just beautiful.

I peeled off the protective plastic bits from the remote, put in the batteries, and plugged it in to the computer.

The FOURTH, fifth and sixth Pissers

Working through the MyHarmony setup, I got all the proper devices set up easily enough. I got to the “Sync” part, and it thought for a while … then told me it couldn’t detect a remote. A footnote in the troubleshooting mentioned that if “other” Harmony software was running it might interfere, but of course it had already refused to start when the old software WAS running. Checked with Task Manager to see if something was left overĀ  – nothing running. Still, no remote detected. Changed USB ports, and the “driver” software failed to install. With a muted scream, I shut down Windows and restarted. Upon logging back in it finally worked, and the remote was programmed successfully.

Taking it to the other room, I pushed “Watch TV.” It turned on the TV, the receiver, the cable box, and … left the receiver on “PS/3”.

The screen had the familiar “Is everything set up OK?” prompt, with a Yes/No selection next to the buttons. The screen stayed lit for all of 2 seconds, then went black. Huh? What kind of help is that? More fiddling with the remote showed that indeed the Help screen does power down after just a few seconds. The main screen stays on a while, but Help does not. Maybe after I get used to it, that will be OK, but … wow. The family is REALLY going to hate this remote.

Finally, after switching things around for a bit, I hit the “all off” button. The cable box turned back on, instead of staying off. So … I hit the “help” button. It promptly turned on the PS3 as well, while telling me it was “fixing the problem.” I had to walk through the devices list hitting Yes/No/Yes/No repeatedly until everything was off. When all was dark, I used the remote to turn things back on and repeated the process, and by Jove if it didn’t do exactly the same thing again. The haters gonna hate … and I can’t blame them. What good is a remote that not only can’t turn things ON correctly, but then can’t even turn them OFF?


Trooping back to the computer, I looked for a way to change the “screen off” timeout. Found one for Backlight, but it was already set to 20 seconds. The help screen goes dark in two. What gives?

I then looked for anything relating to the “all off” button, to figure out why it was turning things back on instead. No options.

Next I went looking for a way to add a pause to the setup. Sure enough, there was a “customize” button to add new commands and change things around. I added a Pause step, and … could not move it above the other steps. They are marked as “Default sequence steps” and cannot be moved, edited or reordered.

I figured, well, I’ll add a pause, and then have it send the “HDMI 1” input command again. Following the pause, I added a new command for the receiver to set the correct input. Wait … (scroll through list, top to bottom and back again) … there IS no input command. Checked the TV device, and same story: there is no way to change the input once the activity does it for you. And you cannot change the sequence or timing of those events.

So I’ve purchased a new remote that STILL fails to control my receiver properly, turns things on when they should be off, hides the help in seconds, and will not allow me to change any of it.

This is progress?

A New (Old) Hope

A little research showed that, in spite of the opening screen verbiage, it IS possible to configure the 650 with the old Harmony desktop software. Sure enough, after I logged in to that, I was able to “transfer” all the settings from my old One and do some advanced tinkering. That software, as infuriating as the interface can be, at least allows things like changing device delay settings.

I upped the device input switch delay from 1 second to 3 seconds, and synchronized with the remote. Hey, presto! Now the remote waits for the receiver to power on before sending input commands. Double prizes! No way! It now also properly shuts down all the devices and doesn’t leave things powered on.

Logitech themselves explained the “power on” issue in a 2010 blog post here that precisely describes the situation and the potential solution. This solution is not available with the new “MyHarmony.com” control panel.

Logitech has gone many steps backward with their remotes. In an attempt to “dumb them down” so much that they are foolproof, they’ve made them such that only fools will use them.

If it weren’t for figuring out that the old software still worked (and that said “old software” fixed issues that the new software created), this remote would be going right back to the store.

Yet another blog site ….

…. just for me to fling random bits into the wild.